Page tree
Skip to end of metadata
Go to start of metadata

Appalachian State University's IT currently follows the model of supporting the latest released version of MacOS (following an internal testing period) and one version previous. Currently, supported versions include MacOS 10.14 (Mojave) and MacOS 10.13 (High Sierra)MacOS 10.15 (Catalina) is currently in the testing phase.

Beginning in February 2020, ITS will begin notifying users of their available eligibility for MacOS upgrades in an effort to ensure system security. The message you see will depend upon how many versions back from our recommended version of MacOS you are currently running and what your device is eligible to run.

Device Running Currently Recommended MacOS Version

Congratulations, if your device is running the currently recommended version of MacOS, you should not receive notifications to upgrade your OS. However, please still be diligent about installing any necessary updates as they become available.

Device Running a Supported Version of MacOS (Eligible for Currently Recommended Version)

If your device is running one version behind our recommended version, you will see the following notification once per month. We recommend using the Upgrade button or upgrading through Self Service at your earliest convenience. (Please note: upgrades, while generally very safe, do run minimal risk of data loss. Please ensure your data is backed up any time before initiating an upgrade. One of our Desktop Support Specialists will be happy to assist with this process. Please visit tech.appstate.edu and submit a request for Computer Support.)

Device Running an Unsupported Version of MacOS (Eligible for Currently Recommended Version)

If your device is running a supported version, but is eligible to run a the currently recommended version, you will see the following notification once per week. We recommend using the Upgrade button or upgrading through Self Service at your earliest convenience. (Please note: upgrades, while generally very safe, do run minimal risk of data loss. Please ensure your data is backed up any time before initiating an upgrade. One of our Desktop Support Specialists will be happy to assist with this process. Please visit tech.appstate.edu and submit a request for Computer Support.)

Device Running an Unsupported Version of MacOS (Eligible for a Supported Version)

If your device is running an unsupported version, but is eligible to run a supported version, you will see the following notification once per week. We recommend using the Upgrade button or upgrading through Self Service at your earliest convenience. (Please note: upgrades, while generally very safe, do run minimal risk of data loss. Please ensure your data is backed up any time before initiating an upgrade. One of our Desktop Support Specialists will be happy to assist with this process. Please visit tech.appstate.edu and submit a request for Computer Support.)

Device Running an Unsupported Version of MacOS (Not Eligible for a Supported Version)

If your device is running two or more versions behind our recommended version, and your device is not eligible to run the latest recommended version, your device has reached End-of-Life and should be replaced at the earliest opportunity. You will see a message about upgrading daily. One of our Desktop Support Specialists will be happy to assist with this process. Please visit tech.appstate.edu and submit a request for Computer Support.


Search Knowledge Base


Submit a Service Request